Tutorial PrestaShop Update 1.3 auf 1.4 23. März 2011

Dieses Tutorial zeigt, wie Sie in wenigen Schritten Ihren PrestaShop von der alten Version 1.3 auf die neue Version 1.4 aktualisieren.

Vorbereitungen

  • Welche Version wird momentan eingesetzt?
    Im deutschen Raum wird relativ häufig neben dem offiziellen PrestaShop auch eine modifizierte Version die „PrestaShop German Edition“ oder die GC Edition eingesetzt. Daher werden drei Versionen unterschieden:

    • PrestaShop original
    • GC Edition (neu ab 1.4.1)
    • PrestaShop German Edition (bis 1.3.1.1)
  • Welche Versionsnummer wird momentan eingesetzt?
    Die Versionsnummer finden Sie im Backend in der Fußzeile, z.B.
  • Welche Module sind installiert?
    Dazu sollten Sie sich einen Überblick über alle installierten Module verschaffen, insbesondere über die Module, die nicht im Standard-PrestaShop bereits enthalten sind, sondern eigene oder nachträglich hinzugefügte Module.

Wir empfehlen immer die Original-PrestaShop Version einzusetzen, oder zumindest eine Version, die keine Veränderungen an den Core-Dateien beinhaltet, um auch mit zukünftigen Versionen updatefähig zu bleiben. Das gewährleistet, dass alle sicherheitsrelevanten Aspekte ohne Umwege über Drittherstellerseiten direkt von der PrestaShop -Website durch neue Versionen aktualisiert werden können.

Dieses Tutorial behandelt daher das Update von der originalen PrestaShop Version 1.3 auf 1.4.

(more…)

PrestaShop Systemvoraussetzungen 24. November 2010

Die technischen Mindestanforderungen / Systemvoraussetzungen für eine PrestaShop Installation sind

  • Linux, Unix oder Windows
  • Web Server (Apache 1.3 unter Linux/Unix/Windows oder IIS 6 unter Windows)
  • mindestens PHP 5.2
  • eine vorhandene oder leere MySQL 5 Datenbank
  • Speicherplatz auf dem Server (mindestens 25Mb, besser > 100Mb)
  • FTP Zugriff auf den Webserver (zum PrestaShop Upload)
  • GD-Libary (i.d.R. bei einer normalen PHP-Installation dabei)
  • optional: Apache mod_rewrite Modul für suchmaschinenfreundliche URLs

Im Browser muss bei der Installation JavaScript aktiviert sein.